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Objectives:

1. Distinguish between the two types of requests in AωωEEARS: point vs area.

2. Familiarize yourself with the basics of Evaporative Stress Index (ESI) data derived from
land surface temperatures. Practice interpreting large and small values and recognize
that there are different algorithms.

3. Practice visualizing and interpreting both temporal (point) and area-based ESI data.
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Motivation For Today’s Tutorial: Drought & Water Scarcity

The figure above was created for the United Nations report “Drought in Numbers,” calling for a global top

priority commitment to drought preparedness and resilience across all regions. Drought is a complex

crisis with roots not only in climate change, but also in social justice and public policy.

• More than 10 million people lost their lives due to major drought events in the past century, with

over 90% of these deaths occurring in developing countries (Guha-Sapir et al., 2021).

• By 2050, between 4.8 and 5.7 billion people will live in areas that are water-scarce for at least one

month each year, up from 3.6 billion today (UN Water, 2021).

• Droughts can disproportionately affect women. While the majority of rural farmers around the

world are women, <15% are the owners of agricultural lands, which means that the most affected

women do not have the ability to make decisions about water scarcity and land use.
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10.1 ACCESSING ECOSTRESS ESI DATA THROUGH AωωEEARS

10.1.1 ECOSTRESS Evaporative Stress Index (ESI) Data

In the previous tutorials, we learned that ECOSTRESS uses land surface temperatures to estimate

evapotranspiration (ET). A related variable is the Evaporative Stress Index (ESI), which is a measure of

potential drought conditions. It is a Level 4 (ECO4) ECOSTRESS data product that can be accessed

through AωωEEARS:

For ECOSTRESS, the drought stress signal is derived from the ratio of actual evapotranspiration (AET) to

potential evapotranspiration (PET):

ESI =
AET
PET

PET represents the theoretical maximum amount of ET that would occur in a location if unlimited water

were available. ESI is a unitless metric (the numerator and denominator have the same units and they

cancel out) that ranges from 0 to 1, with smaller proportions indicating higher water stress (minimal ET

compared to PET) and higher proportions denoting no water stress (ET and PET are equal).

NOTE: The range for ESI may be confusing, as a large number (nearing 1) indicates the absence of

drought conditions, and a small number (nearing 0) suggests drought.
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NOTE: Confusingly, evaporative stress index can have different definitions from study to study. For

example, the Mexico City map in the box below has a scale of -2.5 to 2.5, because it is estimated with a

different formula. Keep an eye out for this!

Today’s Study Location : Mexico City

• Most populous city in North America with>

9.2 million people in the city center and >

21.8 million people in the greater metropoli-

tan area.

• Northern Mexico’s system of > 60 reser-

voirs is currently > 75% drained, leading to

water scarcity (the lack of available water

for human use) for > 30% urban residents

who do not have daily access to water.

• Mexico City sometimes has too little and sometimes too much water. In the dry season

(October - April), droughts dry the land and deplete the water table. In the wet season (May -

September), floods wash through its working-class neighborhoods.

• The year 2021 saw the worst drought conditions in more than three decades for Mexico City

and brought predictions that 2022 might be worse. Today, we are using ECOSTRESS to

compare the drought conditions of 2022 with the extreme conditions of 2021.

10.1.2 Requesting Timeseries Point ESI Data in AωωEEARS

So far, we have been using ECOSTRESS ”Area” data to create maps that visualize our variable of interest,

but AωωEEARS also allows you to submit a ”Point” request. Instead of providing a shapefile or GeoJSON to

define a set polygon area, we can provide GPS coordinates (latitude, longitude) to AωωEEARS, and it will

return a timeseries of our variable of interest for the single pixel that encompasses our coordinates. Today,

we are going to study ESI, but you can return this for any of the ECOSTRESS variables.

1. To begin, go to https://appeears.earthdatacloud.nasa.gov/ and login with your credentials.

2. Use the Extract drop-down menu, but this time select Point. Next, select Start a new request.

3. Enter a useful name for the request you are going to submit, maybe something like “Mexico City ESI

2021-2022”.

4. In the Uploaded coordinates (ID, Category, Lat, Long): section enter the GPS coordinates for Mexico City

as 19.42847, -99.12766.

5. Update the Start and End Date Fields for our dates of interest: 01/01/2021 to 12/31/2022.
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6. Under Select the layers to include in the sample, type the words “ECOSTRESS” and “ESI” Select

ECOSTRESS Tiled Evaporative Stress Index PT-JPL Instantaneous L4 Global. Click on the “+” signs to

add the following layers to your cart:

• ESI

Next, clear the selection of the current category using the small “x” to the right of the ECOSTRESS Tiled

Evaporative Stress Index PT-JPL Instantaneous L4 Global box.

Then, under Select the layers to include in the sample type the words “ECOSTRESS” and “LST,” select

ECOSTRESS Tiled Land Surface Temperature & Emissivity. Click on the “+” signs to add the following

layers to your cart:

• LST

Clear the selection of the current category using the small “x” to the right of the ECOSTRESS Tiled Land

Surface Temperature & Emissivity box.

7. Click Submit to complete the data request. At the top, you should see a green banner:

8. Use the Explore drop-down at the top to monitor the status of your request. Point requests typically

process faster than area requests because the system only needs to pull a single pixel from each scene.
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10.1.3 Requesting Area ESI Data in AωωEEARS

While we wait for the point request, we are also going to create an area request so we can examine how

the drought affects different parts of Mexico City. The procedure to download area ESI data through the

AωωEEARS interface is the same as in previous tutorials on land surface temperature, evapotranspiration,

and water use efficiency.

Drawing and Exporting A GeoJSON File with QGIS

9. First, we will begin by drawing an outline of the metropolitan region surrounding Mexico City and export it

as a GeoJSON that we can load into AωωEEARS.

10. Open QGIS and start a new project by selecting the Project menu, then New.

11. Then to add a basemap, find the HCMGIS menu bar, select Basemap, then pick your preferred map.

Since we are outlining an urban area, we recommend using Google Satellite Hybrid, which overlays streets

and other Google maps data on satellite imagery. Note that clicking on a basemap type automatically adds

a new layer to your map, as seen in the layer browser window.

12. Open the Lat Lon Tools window by selecting the Plugins menu→ Lat Lon Tools→ Zoom To Coordinate.

13. Enter in the following GPS coordinates of Mexico City (formatted as latitude, longitude): 19.42847,

-99.12766.

14. The Lat Lon Tools plugin has found the GPS coordinates for Mexico City and marked them with a “+”

on the map.

15. Next, we want to draw a polygon (i.e., a line that forms the perimeter of the area of interest) that

encompasses Mexico City, so that we can pull the request and download the data from AωωEEARS.

16. Zoom in to the GPS coordinates that we entered and marked with a “+” on the basemap using the

zoom in , zoom out , and pan buttons in the toolbar. If you are on a laptop, you could use the trackpad
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to do the same.

17. Next, we are going to create a new layer on the map by selecting the following menus: Layer → Create

Layer → New Shapefile Layer...

18. Select the “...” option next to the Filename input window. Navigate somewhere you can remember (as

always, we suggest creating a folder for each tutorial) and save it with a worthy filename. “Mexico City

Perimeter” would be an appropriate name.

19. Select UTF-8 for File encoding.

20. Select Polygon for geometry type.

21. Leave the remaining options as their defaults and click OK.

22. Now, it is time to draw the polygon. First, make sure that your new “Mexico City Perimeter” layer is

highlighted in the Layers window.

23. Select the Toggle Editing button on the toolbar to start editing the layer.

24. Then select the Add Polygon Feature button to begin drawing.

25. Draw a polygon that encompasses Mexico City. Don’t worry too much about being perfect or strictly

aligning to the city’s borders; getting the basic shape is fine. Right-click on Windows or Linux and Ctrl-click

on Mac to stop drawing when your shape is complete.

NOTE: Drawing a polygon in QGIS is both straightforward and nuanced. You use successive clicks

with your mouse to create your desired shape. Simple forms such as squares or rectangles are easily

achievable, whereas complex designs take some practice to master. It may take a couple of attempts to

get it to look like what you are envisioning. You can always hit the “ESC” key to clear the polygon and start

over.

26. After you finish drawing, QGIS will prompt you for a feature ID. This is an arbitrary designation for our

purposes today, so simply using the number 1 is my recommendation.

27. Click OK.

28. Select the Toggle Editing button from the toolbar to toggle off editing the layer. QGIS will prompt you

to confirm saving the layer. Select Yes.

29. To export your layer as a GeoJSON file: right-click (Windows or Linux) or ctrl-click (Mac) on the layer in

your layer browser window. Then select Export, then Save Feature As.... In the next window make sure

“GeoJSON” is the selected format.

NOTE: Make sure “GeoJSON” is the selected format. The default for QGIS is “GeoPackage”, which isn’t a

format that AωωEEARS can read as an input. Also, there is a similar filetype “GeoJSON Newline Delimited”

that AωωEEARS can also not read.

30. Select the “...” option next to the Filename input window to choose a logical location to save your

GeoJSON file.

31. Name the file something appropriate, perhaps “MexicoCity-Outline.”

32. Uncheck the box labeled “Add saved file to map.”

33. Click “OK”.
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Creating an Area Request for Mexico City in AωωEEARS

Return to AωωEEARS to create a new area request. We have preselected dates with good data coverage

(few-to-no clouds, orbit that aligns with a single image for the area of interest) in 2021 & 2022.

34. Use the Extract dropdown menu to select Area. Next, select: Start a new request.

35. Enter a useful name for the request you are going to submit, maybe something like “Mexico City 2022”.

36. Drag and drop (or use the click here to select the file link) to upload the GeoJSON file we just exported

in steps 10-33. The map should be updated with your polygon surrounding Mexico City.

37. Update the Start and End Date Fields for our preselected date of interest: 04/05/2022 to 04/05/2022.

38. Under Select the layers to include in the sample type the words “ECOSTRESS” and “ESI” Select

ECOSTRESS Tiled Evaporative Stress Index PT-JPL Instantaneous L4 Global. Click on the “+” signs to

add the following layers to your cart:

• ESI

Next, clear the selection of the current category using the small “x” to the right of the ECOSTRESS Tiled

Evaporative Stress Index PT-JPL Instantaneous L4 Global box.
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Then, under Select the layers to include in the sample type the words “ECOSTRESS” and “LST.” Select

ECOSTRESS Tiled Land Surface Temperature & Emissivity. Click on the “+” signs to add the following

layers to your cart:

• LST

Clear the selection of the current category using the small “x” to the right of the ECOSTRESS Tiled Land

Surface Temperature & Emissivity box.

39. Under Output Options, we want to use GeoTIFF (Geographic Tagged Image File Format; essentially, an

image file where the corresponding geographic information is embedded in the file) and Native Projection

for projection.

40. Click Submit to complete the data request. At the top, you should see a green banner:

41. Repeat steps 34 - 40 with the same layers and GeoJSON file. Call the request “Mexico City 2021” and

change the date to 4/28/2021. Or to be even more efficient from the Extract page find your “Mexico City

2022” request in the “Copy a previous request” section and change the date to 4/28/2021.

42. Use the Explore drop-down at the top to monitor the status of your request. Requests will likely go

quickly, given that it is only one day’s worth of data.

10.2 VISUALIZING ESI TIMESERIES POINT DATA IN AωωEEARS

43. When your first timeseries point data request (“Mexico City ESI 2021-2022”) is complete, use the link

on the Explore page to access the details. AωωEEARS returns this data in a .csv spreadsheet that can be
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opened with free statistical software such as R, the paid program Microsoft Excel, or the free alternative

Libreoffice Calc. These software options can create graphs and run statistical comparisons.

44. You can also use the AωωEEARS interface to do some light visualizations.

45. Our goal for the ESI timeseries point analysis is not to visualize the data in space, but rather to compare

the differences between the two years (the known drought year of 2021 and 2022). The benefit of this point

data is that AωωEEARS has conveniently packaged our variable of interest in an easy-to-manage format to

track changes over time. The disadvantage of this type of data retrieval is that it can only be done for a

single pixel per request.

46. First, select the ECO L4T ESI 002 ESI layer.

The top panel displays the entire timeseries for the dates we have requested. The bottom panel compares

years by plotting different years in our data in different colors.

Notice that the dry season (October - April) has much higher drought stress (low ESI) compared to the

wet season (May - September). Our goal was to compare 2022 to the known drought year of 2021. What

conclusions can you draw from these data?
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10.3 VISUALIZING AREA ESI DATA WITH QGIS

10.3.1 Download Area ESI Data in AωωEEARS

47. By now, your area requests should be complete. From the Explore dropdown menu at the top of the

AωωEEARS interface, click the download button (middle blue button) for the first area request “Mexico City

2022”.

48. Select the following filename:

ECO L4T ESI.002 ESI doy2022095170707 aid0001 14N.tif. Download the file using the Download button,

which for some reason does not look much like a button, in the upper right corner of the screen. Save the

file somewhere you can remember.

49. Repeat steps 47 - 48 to download the file from the second request “Mexico City 2021” to download the

following filename:

ECO L4T ESI.002 ESI doy2021118181115 aid0001 14N.tif

10.3.2 Adding a Google Satellite Basemap

50. Switch to QGIS and start a new project by selecting the Project menu, then New.

51. To add a basemap, find the HCMGIS menu bar, select Basemap, then pick your preferred map. For

today’s map, we will use Google Satellite. Note that clicking on a basemap type automatically adds a new

layer to your map, as seen in the layer browser window.
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10.3.3 Add in ESI layer

52. Use the browser window to find the folder where you saved the 2022 ESI file:

ECO L4T ESI.002 ESI doy2022095170707 aid0001 14N.tif. Double-click on it to add it to your map. Again,

notice that the layer from this GeoTIFF file is now also listed in the Layers window.

NOTE: QGIS can automatically zoom to your layer’s area of interest by right clicking (ctrl-click on Mac) on

the layer and selecting Zoom to Layer(s).

53. Now, you have ECOSTRESS ESI data on your map, but we need to change it from grayscale. Right-click

(ctrl-click on Mac) on the layer name in the Layers window and select Layer Properties.

54. On the menu bar to the left, select Symbology and change Render type to Singleband pseudocolor.

55. QGIS has automatically determined the minimum and maximum values from the datafiles; however, we

are going to want to compare two different years and need to match them. The ESI range is 0-1, so specify

0 as the minimum and 1 as the maximum.

56. Now, we need to change the color ramp to effectively communicate ESI. Let’s select the “Reds” option,

but remember that the scale for ESI is inverted (0 indicating drought stress & 1 indicating non drought

conditions). To address this, check the invert color ramp checkbox.

57. Click apply.

58. Then click ok.

59. Finally, add the polygon border from your Mexico City GeoJSON file by double clicking on it in the

Browser window. Right-click (ctrl-click on Mac) on the layer in the Layers window and change the symbology

to outline blue.

60. Repeat steps 52 - 59 for the Mexico City 2021 data to create two separate maps comparing. How does

2022 compare to the 2021 year of extreme drought in Mexico City? What conclusions can you draw from

the ECOSTRESS observations of ESI?

10. EVAPORATIVE STRESS INDEX WITH ECOSTRESS 12



I.C.E.C.R.E.A.M. TUTORIALS
Observing Earth from Above (Env 329) v24.06

Schmid College of Science and Technology, Chapman University

Make a Map Assignments

1. Watch the YouTube video: Careers in Observing Earth from Above - Ufuoma Ovien-
mhada

2. Make a map of evaporative stress index for an area of interest. Try to identify an
interesting comparison or contrast based on some aspect of climate, edaphic (soil)
conditions, plant community composition or structure, land use, or some disturbance.
If you complete your map and do not find strong differences, don’t worry! The most
important part of this exercise is to practice asking a question, collecting the data to
answer your question, and thinking about what you found.

3. Find a classmate and compare maps. Is your classmate doing anything differently that
can help improve your map? If so, revise accordingly!

4. Submit your evaporative stress index map, along with a short description. In partic-
ular, your description might address any interesting observations and address any
limitations of your analysis.

Datafiles

In case you encountered any issues with the AωωEEARS database, here are copies of the
ECOSTRESS GeoTIFF file for Mexico City ESI:

• 2022: ECO4ESIPTJPL.001 Evaporative Stress Index PT JPL ESIavg doy2022095170707 aid0001.tif

• 2021: ECO4ESIPTJPL.001 Evaporative Stress Index PT JPL ESIavg doy2021118181114 aid0001.tif

Recommended Citation: Forsythe, J.D., G.R. Goldsmith, and J.B. Fisher. 2023. Observing Earth from Above
Tutorials. Chapman University. https://jeremydforsythe.github.io/icecream-tutorials/

This work is supported by funding from NASA ECOSTRESS Mission Grant #80NSSC23K0309 (I.C.E. C.R.E.A.M.:
Integrating Communication of ECOSTRESS Into Community Research, Education, Applications, and Media) and is
openly licensed via CC BY-NC.
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